Current system status

Bulk Data Exchange (BDE)
Incident Report for ATO Place holder
Resolved
This incident has been resolved.
Posted Jul 06, 2019 - 13:04 AEST
Investigating
BDE, which may affect file transfers is currently not available. We are working to restore this service as soon as possible.
Posted Jul 06, 2019 - 11:21 AEST